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1 Introduction 
 

 
The QGrip-UI (User Interface) is an executable, QGrip.exe. The QGrip.ini contains the connection 
string to the QGrip Database and needs to be present in the same directory as the executable. 
Before you can start using QGrip you will need to ask your QGrip-Admin to arrange access for your 
AD account. 
 
This document gives an outline of key aspects of the QGrip-UI, including: - 

- standard button functionality options across the various windows; 
- the main window and the message bar; 
- how different types of windows work; 
- a description of the File menu with “My Stuff”; 
- a description of the Help menu; 
- explanation of error messages. 

 

2 Standard Buttons & Toolbar 
 
Standard Buttons 
 
Depending on the current window, different buttons may be available. Buttons will only be enabled 
if they can be used on the current object. 
 

Button Action 
Refresh Refresh the content of the current tab-page. 
Details Open a new window with the details of selected row(s) in the current tab-page. 

When Details button is present you can also double click on a row to show the 
details. 

New Open popup window to enter new object. 
Delete Delete selected rows in the current tab-page. 
Save Save changes in the window. 
Save+Close Save changes and close the window. 
Close Close the window, no questions asked about unsaved data. 

 
Toolbar 
 

 
The toolbar contains Items for New, Edit, Save, Delete, Close (Exit) and Refresh. The toolbar Items 
are only enabled if they can be used. 
 

3 Main Window 
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The main window is only meant for browsing thru the components in the QGrip CMDB. No changes 
can be made in this window except that Notes can be added to various objects. 
 
You can navigate to items you want to change or request by using the menu at the top of the 
window.  
 
QGrip users will only see objects in the CMDB that are related to the Applications that they are 
authorised for. Applications that have been marked as “IsService” are only visible to the QGrip-
Admin users. 
 

 
 
Menu Bar 
 

 
You will only see the Menus you are authorised for. If you click on a Menu, only the Menu Items you 
are authorised for, will be enabled. 
 
Details for the different Menus are outlined in the following documents: 

Doc-Tab Title Remark 
QGrip-UI Admin Menu 

Admin Menu-Config 
Admin Menu-Access to QGrip 
Admin Menu-Infra 
Admin Menu-Jobs 

Only QGrip-Admin 

QGrip-UI Application Menu  
QGrip-UI Jobs Menu  
QGrip-UI Trace Menu Only QGrip-Admin 
QGrip-UI Reports Menu Only QGrip-Admin 

 
Filter 
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If you only want to see applications that you have marked as MyApps (see MyApps section), check 
MyApps in the filter. QGrip saves this setting until you change it. The checkbox AppIsService will only 
be visible to QGrip-Admin users. If AppIsService is checked you will also see IsService Applications. 
 
Explorer 
 

 
Use the Explorer to navigate to the Object you want to see. Use the most appropriate starting point 
and drill down as required. The data will be filtered according to the path. When you click on an 
object in the Explorer, the Current Object on the right part of the window will change and the 
appropriate tab-pages with information will change.  
 
Current Object 
 

 
The header contains the name of the Current Object, the first tab-page the details of the Current 
Object and the rest of the tab-pages contain relevant children of the Current Object. 
In this example, the Current Object is the Organisation Grip on SQL. The tab-page Units contains Grip 
on SQL’s Units and the tab-page Applications its applications.  
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If the current tab is a list, you can Right-Click and copy Row, Sheet or Selected Rows to clipboard. 
 
Message Bar 
 

 
 

Message Type Description 
Personal Result of a job/action started by you 
Error Job/action failed. 
Approval Approval of a job Request is needed 
TeamMember Approval of a Team Membership request is needed. 
Warning Stuff that needs to be fixed because of Inconsistency, Incompleteness etc. 
Hidden Warnings that have been hidden. 

 
The message bar is refreshed every 30 seconds and shows per Message Type the number of 
messages that concern you or you are authorised to do something about it. If you have no messages 
the message bar will be empty. 
We advise you to remove/solve messages as soon as possible so you can see at once that there is a 
new message.  
If a Warning can’t or doesn’t need to be actioned on straight away, you can hide it until a defined 
date – after which it will re-appear in Message Bar. 
If you have Requested a job, you will always receive a Personal message when finished or Denied. No 
need to waste time in the Request window, just wait for the message. To see the actual messages, 
click on the Message Button. 
 

4 List Windows 
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A list window is a window containing one or more tab-pages and the buttons are in the Upper Right 
Corner.  
 
One or more rows in the current tab-page can be selected and the buttons will work on the selected 
rows. Whenever appropriate, the window has a filter to narrow down the selection in the current 
tab-page. Changing of the filter items will cause an immediate refresh of the data in the tab-page. 
 

5 Select/De-Select Windows 
 

This window type does not have a Save button. Selecting (Add) or De-Selecting (Del) items will auto-
save the action immediately.  
 
The list of selected items is always on the left and the remaining candidates are on the right. 
 

6 Edit browse Windows 
 

 
This Window type has the same layout as the main window with an Explorer to navigate to the 
object or object type you want to change. 
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The header contains the name of the Current Object, the first tab-page the details of the Current 
Object and the rest of the tab-pages contain relevant children of the Current Object.  
The buttons and the items in the toolbar work on the current object(s) which is in the selected tab-
page.  
 
New and Edit 
If the selected tab-page contains a list, the current object is the first selected row. 
 
Delete  
If the selected tab-page contains a list, all selected rows will be deleted. You will need to confirm the 
delete. A check will be performed to see if delete is possible. 
 

7 New/Edit popup Windows 
 

 
This is the window type where New objects are created or changes can be made. 
When saving, verification will take place and the input fields will be validated.  
 

Button Action 
New Reopen the window without saving changes, no questions asked about unsaved data. 
Save+New Save current data and reopen the window for adding new object. 
Save Save changes in the window. 
Save+Close Save changes in the window and close the window. 
Close Close the window, no questions asked about unsaved data. 

 

8 Notes 
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Simple notes can be added to the objects listed above. 

 
Selecting a row in the Notes tab-page will show the entire note text. 
 

 
A new Category can easily be added or renamed by Right-Click on the Category drop down. The 
Categories are global and renaming a Category will update the Category in all Notes. 

9 Messages Windows (Clean-up) 
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How to clean up messages in the message bar. 
 

9.1 Personal 
 
When you have seen a Personal message, you should try to note and/or action as applicable, and 
delete it as soon as possible. To delete, select the rows you want to delete and press Delete. If you 
have deleted all messages, the window will close automatically. 
 

9.2 Error 
 
When you have acted on an Error message, you should try to delete it as soon as possible.  
 
Ignored 
If the messages are not really relevant, select the rows and press Ignored.  
 
Solved 
If you want to add a comment on how you solved the errors, select the rows and press Solved. A 
popup will appear where you can add the solution to the problem. 
 
When all Error messages have been Ignored/Solved, the window will close automatically. 
 

9.3 Approval 
 
Approve 
Select the rows and press Approve. The Job will start running when it is due. 
 
Deny 
Select the rows and press Deny. A popup will appear were you need to enter a reason. The Job will 
be removed from the Queue and the requester will receive a Personal message that the job has 
been Denied. The reason you entered will be visible to the Requester. 
 

9.4 TeamMember 
 
Approve 
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Select the rows and press Approve. The QGrip user will be added as Member of the Team. The 
Requester will receive a Personal message that his/her Request has been Approved. 
 
Deny 
Select the rows and press Deny. A popup will appear were you need to enter a reason. The requester 
will receive a Personal message that Team Membership has been Denied. The reason you entered 
will be visible to the Requester. 
 

9.5 Warning 
 
You cannot get rid of warnings by simply deleting them, the cause needs to be solved.  
However, you can hide a warning message until a later date if it is lower priority and you are 
confident that deferral will not impact your ability to resolve adequately. To do this you should 
select the row to be deferred and press HideUntil. You will then be asked for a hide until date. 
Hidden warnings can be unhidden at any time by selecting the rows and pressing UnHide.  
 
Note that warning messages with ‘Category Warning’ are considered important and cannot be 
hidden. 

10 Menu: File - My Stuff 
 

10.1 MyDetails 
 

Required QGrip Role Menu 
None – All users File -> MyDetails 

 

 
The first time you use QGrip you will need to complete your personal details. You can change these 
details at any time via the menu.  
 
Display Name: What other users will see. 
User Name:  Your name 
Email:  Your email address (*) 
(*) If you are QGrip-Admin, this email address will be used to send reports on errors etc. if external 
monitoring has been activated. 



 

12 
 

 QGRIP-UI – GETTING STARTED  
 

 

10.2 MyApps 
 

Required QGrip Role Menu 
None – All users File -> MyApps 

 

 
This is a handy shortcut. Add the application you are momentarily working with as MyApps. When 
you need to select an application in QGrip, only a list of these applications will be shown in the 
selection. If you uncheck MyApps you will see all Applications you are authorised for. 
 
Everywhere within QGrip where MyApps is available, you can right click on the Application to Add or 
Delete from  MyApps.  
 

 
When MyApps is not checked, you can add the current Application to your MyApps. 
 

 
When MyApps is checked, you can delete the current Application from your MyApps. 
 

10.3 MyAuthorisation 
 

Required QGrip Role Menu 
None – All users File -> MyAuthorisation 
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In this window you can see of which teams you are member and what you are authorised for within 
QGrip.  
 

 
Under the tab PerApplication, you can select an application and see what your authorisations are for 
that specific Application.  
 

10.4 MyTeams 
 

Required QGrip Role Menu 
None – All users File -> MyTeams 

 

 



 

14 
 

 QGRIP-UI – GETTING STARTED  
 

In this window you can manage the Teams you are member of. In the left top pane, you see the 
MyTeams (the Teams you are member of) and in the left bottom pane, you see Other Teams (the 
Teams you are NOT member of). By Clicking on a Team in one of these to panes, the Team details 
will be shown in the right pane. 
 
To Terminate Membership of teams, select the Teams in the left top pane and press [Terminate 
Membership]. You will need to confirm the request before termination is executed. 
 
To Request Membership of teams, select the Teams in the left bottom pane and press [Request 
Membership]. You will need to confirm the request before your request is filed.  

 
As long as your Request has not yet been processed, your membership has Status “Awaiting 
Approval”. When your Membership Request has been Approved or Denied, you will receive a 
Personal message. 
 

10.5 MyDatabases (Local) 
 

Required Authorisation Menu 
PostClone Script File -> MyDatabases (Local) 

 

 
This menu item will only be enabled for QGrip users that are authorised to Edit PostClone scripts for 
one or more Applications.  
 
When a PostClone script has been edited it should be tested. To prevent that you accidentally test it 
on the wrong database, you will only be able to select a database you have defined here. We 
recommend that the database is a local database that is not part of the QGrip configuration but it is 
not a restriction. Just make sure it is not a production database. You need to first add the Instance 
and then the database. 
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11 Menu: Help 
 

 
The help menu is available to all users except for SystemInfo that is only available to QGrip-Admin. 
 

11.1 About QGrip 
 

 
Shows information about your QGrip configuration. 
 
The Current version of the QGrip-UI, Database, Remote Jobs executables that run on the QGrip 
Servers and the SQL Installer. 
 
License Information with the License Key and the type of License key you are using, when it expires 
and Level, the Max Instances and Max Users you are allowed to add and what you are currently 
using. 
 
Updating the License Key can only be done from the QGrip Setup on one of the QGrip Servers. 
 
 

11.2 Documentation 
 
When ‘Go to Website’ is selected, a browser will be opened and take you to the Documentation 
page on our website: 

 https://griponsql.org/qgrip/documentation 
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Use ‘Copy Website URL’ to copy to Clipboard instead. 
 

11.3 System Info 
 
If you need to open a support ticket to report a bug or malfunction, Grip on SQL need some minimal 
information about your configuration. 
 

 
Save this information to a file and add it to your support request. 

12 Error Messages 
 
Various error messages may appear in a pop-up window when you are starting up and/or working in 
the QGrip-UI.  In most cases the user will not be able to resolve these and so should contact the 
designated QGrip Administrators. 
 

12.1 Error messages on start-up 
 
When starting QGrip, you can encounter one of the following Error Messages: 
 

Message Reason Solution 

 

The entitled number 
of users according to 
existing License Key 
has been reached 
and you cannot be 
added as a QGrip 
user. 

Extend the license or 
set another user in 
QGrip as InActive and 
Activate this user. 
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Your account in 
QGrip has been set 
as InActive. 

Activate this user. 

 

The current version 
is not compliant.  

You will need to 
download the latest 
version from the 
Database, click OK. 

 

The PowerShell 
version on your 
Workstation is not 
compliant and needs 
to be updated. 

Workstation update 
with correct 
PowerShell version. 

 

The DOT-Net version 
on your Workstation 
is not compliant and 
needs to be updated. 

Workstation update 
with correct DOT-Net 
version. 

 

QGrip database 
according to 
QGrip.ini file is not 
available. 

Is QGrip DBHost / 
Database up and 
running? 
Is the connection 
string in the used 
QGrip.ini file correct? 
Does the User have 
access to the QGrip 
DBHost / Database 
direct or via AD-
Group? 

 

12.2 Error messages during use of QGrip-UI 
 
Whilst using QGrip, you can encounter one of the following Error Messages: 

Message Reason Solution 
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 Authorisations have 
been revoked. 

 Your QGrip account 
has been de-activated.  

 QGrip has been 
updated with a new 
version. 

Re-Start QGrip. 

 

The QGrip Database is 
probably being upgraded 
with a newer version. 

Wait a while and Re-
Start QGrip. 

 

You have become more 
Authorisation that will 
take effect when you login 
again. 

Re-Start QGrip. 

 

The QGrip DBHost / 
Database is not available 
any more. 

Re-Start QGrip. 
 

 
 
 
 
 


